Auto Repair Forums

Full Version: 05 Escape Battery Light
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The battery light is on fr my 2005 Ford Escape XLT V6 3.0. I had the battery tested they said it was fine. Could be the alternator so I tested it. It was bad and replaced it. (NOT EASY AT ALL!!!!) The light is still on. Any ideas on what it could be?
Have you had any starting problems? Or is it just the light is on?

If there is a bad connection anywhere it could cause the light to be on. The battery terminals need to be clean, free of corrosion, and tight on the battery. The other end of the cables are the same. The Ground usually connects to the engine block somewhere. It must be clean and tight. The Positive cable usually goes to the starter. Again, clean and tight. The connections at the alternator must be clean and tight. I like to use Dielectric Grease when making any electrical connection.

You may want to check all of the fuses and relays. Look at the wiring to see if something is rubbed, melted, pulled and stretched, corroded, or unplugged. Is the belt on properly and tensioned properly?

Is the Check Engine or Service Engine Soon light on? If so, you should have the computer scanned, Record the Code Numbers, post those NUMBERS here for review, and have the computer cleared. If the light comes back on the new codes may relevant to your charging issue?

That should give you some common things to look for. Please let us know what you find.
Reference URL's