Auto Repair Forums

Full Version: wipers
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
My Question: My daughter has a 1989 Plymouth Acclaim LE. She replaced her wiper motor on 12/3/2009, again on 1/20/2009, again on May 1/2010 and she calls today to tell me it is not working again. All have been NAPA rebuilts. The last two, and maybe this replacement, covered by their part warranty. Each time the bad part has also caused the fuse to blow, and a replaced fuse just blows again. We now suspect that the probability that all these wiper motors are bad is pretty low. Are they getting zapped by something up stream? Doesn't the motor have some internal protection against such?
Testing my memory here because my father had one of these and recalling two problems.

The first is many of these are mounted inside the cowl area and water backs up (clogged drain hoses?) causing them to "go under" and they are not water tight! They take weeks or months to totally dry out and in the meanwhile the moisture does it's damage.

The second is the "contact wiper" (the internal rotary switch that allows them to park) is a weak spot and often burns through under high draw conditions. These conditions include leaving the switch on with the blades frozen to the glass and binding linkage.

Also recalling that NAPA has a decent reputation for warranty with few problems over the years so getting a replacement should not be a real issue. OTOH, I'd look closely at the above problems and see what you can do to solve them. It may be as easy as blowing out the cowl drains at each oil change, which is something I do with my own cars.
Reference URL's