Auto Repair Forums

Full Version: 2004 Grand Cherokee no TCC engagement
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Changed thermostat because wasn't running up to temp. Now fine but still no TCC Lock-up. TPS, Man vac, trans temp, and other data look normal. But governor pressure not keeping up with Desired when driving conditions would normally engage TCC. des gov press closely matches gov press during take off and all upshifts, psi from zero up to around 40psi. But then duty cycle drops to 1, des gov pressure goes to 127 (which I believe is normal), but actual gov pressure only makes it up to 68 or so psi. Pressure/pump failing? Is there an external method of actually measure this pressure? Pressure sensor seems dead on for all the lower pressures... drives and shifts perfect other than never engages tcc. No codes present. Thanks if anyone has information!
Could be one of several things. There's a temp sensor on some units to keep it from going into lock up when the oil is cold and I believe there's also a pressure sensor to tell the ECM what's going on. Then of course there's the TCC solenoid on the back of the valve body (inside the pan) that could just be open circuit or sticking. Something along these lines might be better diagnosed with a full function scanner where you can request a specific function to see what happens.

Maybe one of our other moderators has something to add. He used to work in a trany shop and might be more familiar with this specific problem.

If you can get us a bit more info, like the trany model, engine size, and mileage on the vehicle it may help.

BTW, here's an article with a pic so maybe you can identify the TCC sol plug and do an ohm meter test. (this guy has the TCC stuck in lock up)
The one other thing; besides what Rupe mentioned, that I can think of, would be the torque converter itself. If the converter fails the pressure will blow around it causing the “Low Pressure” situation that you are describing.

There are several test ports on the transmission case where you can hook a gauge to test the pressure. You would need a transmission specific manual to show you these ports & what each one is for. Unfortunately I don’t have access to those manuals anymore. You also would need a gauge with a long hose so you can route it into the drivers compartment so you can watch the gauge while driving.

If you haven’t dropped the pan yet, it may hold clues. Is the oil Brown &/or smell burnt? What kind of debris is in the bottom of the pan? Cut the filter apart and see what is in it. If there is clutch material it most likely came from the torque converter.

Along with the information that Rupe requested, please include what type of scanner you are using.
Thanks Rupe! I deliberately tried to keep my initial post short... I'm working with Snap-On Modis. Only 104K miles on it. My buddy just bought it... temp plate still on it. It's got the 4.0L and runs great. He has a 2001 GC as well, which has been slowly losing coolant into the oil so engine is now junk but trans in that was recently rebuilt. I'm hoping they are the same transmission...
I believe this has the 42RE but have not figured out how to confirm that. I only found a barcode sticker for any numbers on it. And the pan number, which is 52118779AD.

What I see happening is the PCM isn't commanding the TCC to engage. Scanner Troubleshooter is useless LOL, by symptom there is no menu for TCC not engaging. It is not setting any codes. I'm more familiar with GM then Jeep, but I'm pretty sure the PID for TC-SOL should change to "on" if it's commanded on regardless of it's condition. Can anyone confirm this???

Without listing them all out, all other PID's are normal including trans temp. I have a trans guy I can call next week...

Thanks Garner!
That makes sense IF TCC-SOL PID doesn't change to "on" unless solenoid is successful vs just being commanded?? I suspect it's waiting to see gov press come up before commanding TCC-SOL. Apparently whatever it's doing (or not doing) isn't seen as a problem by the pcm as it's not generating any codes. All readiness monitors are done except EVAP. I've driven it 3 times from cold start... don't know how many miles LOL. Additional info in my reply to Rupe...

Haven't dropped pan yet. Fluid looks a little old, dirty, but not bad. Not burnt.
I have been out of transmission Repairing/Rebuilding for so many years that I can’t remember all the details. I can say that the Modis should be a good tool to do everything you will need.

One thing that many people miss when trying to diagnose a “No Command” problem is, “What are some of the ‘simple’ things that could stop the command?” Most vehicles won’t command the torque on until they up to temperature, as Rupe mentioned. Another thing could be the brake light switch. If the lights are on or the computer reads a closed brake circuit you won’t have lock up. You should be able to check that with the Modis. (Click “Brake Light State” in the custom data stream section.) Most won’t lock up until they reach 45mph so you should check all of the speed sensors to be sure that the computer is receiving the proper data. (Click any speed sensor data; ISS, OSS, RF Wheel SS, etc. in the custom data stream.

Other than that I remember replacing many Transmission Pressure Sensors & Pressure Regulators on the 42RE’s. They usually set a code though. We used to get books through “Transtech” & “Transtar” that broke everything down very well. If I can find information on them I will post back later.

Please keep us updated as to what you find.
Here's the link to Transtar. Look at the small menu at the top of the page. Point to "Catalogs" and the menu will expand. You should be able to find the information that you need there or under "Products." Down at the bottom of that menu there is "Service items, Tools & Manuals." Also, just poke around the whole site. You might find the information that you need right on the site?
All the "simple" things look OK. But I didn't look at wheel speed sensors, but I will. No abs code in it either...
My earlier fluid description was based on what I was told prior. I just checked it myself and with it running but cold. It's reading way over full and with bubbles all over it on the stick. Otherwise, as described when wiped on a white tissue. Only a little dirty and not burnt. Not sure if it's aerated from being over full, or reading high because it's getting aerated. Something seems up with it though... I'll see how it looks when hot, too.
The air bubbles could be throwing the pressure reading off so if you can borrow one of those "suction pumps" to lower the level without taking the pan down that would be a good start. The one I have at work is graduated so I'd take out a quart then read the stick again. If the bubbles continue I would suspect a bad seal on the filter tube or possibly a broken filter. They are made of plastic and I have seen a few fall apart over the years. It would be nice to find something that simple causing your issues, eh?

BTW, if you have to take the pan down you can also check the torque on the valve body bolts. I have seen bolts falling out causing weird issues. (sucking air and internal leaks)
LOL... we think alike! I just got back from sucking out a quart of hot fluid. No help. Looks good on stick not running. All bubbly on stick as soon as start and idle. Definitely air, not coolant! Pan will come off next week... suspect that, just as air in brake fluid prevents good braking, air in trans fluid prevents it building enough gov press... will update what I find!
Thanks for the up date and good luck!
Pages: 1 2 3
Reference URL's