Auto Repair Forums
07 ford f150 xl clutch issue - Printable Version

+- Auto Repair Forums (http://www.autowebrepair.com/forum/upload)
+-- Forum: Foreign & Domestic (/forumdisplay.php?fid=1)
+--- Forum: Ford (/forumdisplay.php?fid=2)
+--- Thread: 07 ford f150 xl clutch issue (/showthread.php?tid=9905)



07 ford f150 xl clutch issue - npomme - 02-18-2014 06:45 PM

Hey all,

Like the subject says I have an f150 xl standard trans. About 60000 miles on it. My father in law was towing a 70s dodge ram with it a few months back (it is his rig), and when trying to back it into place ran the clutch into the ground to where you could shift it when it was off, but when you started the car the clutch would not disengage to shift. So I put a new clutch kit on there. It being my first time doing it I followed the directions. the clutch kit came with only the two plates and the alignment tool. after I put everything back together there was still the same issue. bled the slave cylinder and on the side of this transmission it had a window to see the slave cylinder working when the hydraulic hose was back on and there was plenty of pressure in the pedal, but still would not disengage the clutch. Transmission is off again to make sure i installed the clutch plate the correct way, I did, and that I didnt bend the shaft when putting the transmission back in. Everything I see looks like I installed it correctly. The pilot bearing looks good, and the fly wheel has minimal heat discoloration. Can the slave cylinder go bad without it leaking? the fluid in the slave tank was full after the clutch went bad. Any help or tips would be great.


RE: 07 ford f150 xl clutch issue - Rupe - 02-18-2014 10:32 PM

First off, I doubt you can bend the input shaft on the trany. It is hardened steel and if anything it will break, although I have never seen one break short of using a 10 pound hammer slamming from the side.

You didn't mention if you can see the clutch bearing move when pushing on the pedal. If it doesn't move then you either have air in the system or the master cyl for the clutch is no good. Seeing as you have the trany out I would replace both the master and the slave then double check your work to make sure the disc is in correctly.

BTW, air in the system is enough of a problem that some companies offer the master with the slave AND is conecting pipe as an assembly / kit ready to go. Saves all of those issues you seem to be having with bleeding.

Let us know how you make out as it may help someone else reading these boards.