Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2nd fuel pump bad
10-02-2014, 10:43 PM
Post: #1
2nd fuel pump bad
took my blazer to certifed mech. had my fuel pump changed they said it was fixed .got there paid for it. went start it would not start left it there. they put in 2nd pump. had blazer 1 week with the 2nd pump put in. now this pump bad. this will be the 3rd pump going in. the 2nd one is a ac fuel pump. ran good for 7 days wont start .any clues whats going wrong or what their doing wrong
Find all posts by this user
Quote this message in a reply
10-03-2014, 06:42 AM
Post: #2
RE: 2nd fuel pump bad
Did they change the fuel filter? A clogged up filter will over work a pump and kill it prematurely.

Thanks for using the forum,
Garner

Interested in Mining? Look here: Coal Mining, PA
Visit this user's website Find all posts by this user
Quote this message in a reply
10-03-2014, 10:53 AM (This post was last modified: 10-03-2014 11:36 AM by myispheres.)
Post: #3
RE: 2nd fuel pump bad
yes it was changed the fuel filter . the first fuel pump put in was carter. it was bad from the start . paid for it went to start it. pressure was bad .the 2nd fuel pump they put in is A C fuel pump . got the blazer started up drove fine from last friday till this thursday .this will be the 3rd pump going it .makes no sense

I just found out when I called them . they did not clean the tank or drain the gas out. the said they had no were to put the gas . the tank was full I know that. my gas gauge was not working .when i got it back the 2nd time gauge read full now it reads 3/4 tank of gas .they say it might be a regulator . the trucks at a place called his hands helping auto in midland . now am not sure what to think 3 pumps in 1 month
Find all posts by this user
Quote this message in a reply
10-03-2014, 08:19 PM
Post: #4
RE: 2nd fuel pump bad
Without being there to check the vehicle myself it is hard for me to know what the problem is. It could just be that you got 2 bad fuel pumps. Some people are just lucky that way.

From here, I can only ask questions to try to come up with a solution, like:
Did anyone check for trouble codes with a Full Function Scanner? If there were codes, what were the code Numbers?

Did anyone actually put a gauge on the fuel system to check the pressure? If you look in the repair manual there will be an operating range for the fuel pressure. If your pressure is to high, it may be a bad regulator.

Did anyone check for proper voltage and ground at the pump? To high or low of voltage isn’t good. Either way will cause the motor to run hot and possibly burn up. A poor ground can cause excessive heat in a motor and cause it to fail.

Those are just a few thing that I can think of right now. Please let us know what you find.

Thanks for using the forum,
Garner

Interested in Mining? Look here: Coal Mining, PA
Visit this user's website Find all posts by this user
Quote this message in a reply
10-04-2014, 03:01 AM
Post: #5
RE: 2nd fuel pump bad
on the first pump it ran 65 then it drop to 50 . it did start it was hard to start the motor was shaking like it was little gas was getting to it wanting to start. they told me its bad pump . I will ask them if they did any trouble codes . on the ground matter think they told me they had to put a new harness on. ill ask what they did if they tell me and shoot it back to the fourm this is all can tell now 2nd one was doing fine starting right up and running fine. till it would not start the 2nd one i could hear the pump running so it did not burn up. blazer are so much trouble i seen on here till i talk to them monday thanks Garner
Find all posts by this user
Quote this message in a reply
10-05-2014, 05:00 PM
Post: #6
RE: 2nd fuel pump bad
Another thing to look at is the wiring going to the pump. Sometimes these little wiring harnesses corrode and cause issues.

Being way2old is why I need help from younger minds.



[Image: crybaby.jpg]
Find all posts by this user
Quote this message in a reply
10-09-2014, 01:38 PM (This post was last modified: 10-09-2014 02:56 PM by myispheres.)
Post: #7
RE: 2nd fuel pump bad
hmm now they tell me map sensor was bad . the check engine light works but was not on telling some thing wrong . and that the plugs were burnt. which they told me the frist time the plugs was fine getting spark and if they did a scan the frist it would have showed map sensor bein bad .now am wondering if the fuel pump was ok and just a bad map sensor now am wondering what they did do hmm
Find all posts by this user
Quote this message in a reply
10-09-2014, 05:48 PM (This post was last modified: 10-09-2014 05:48 PM by Rupe.)
Post: #8
RE: 2nd fuel pump bad
Something out in left field they may have overlooked is poor running can damage the cat converter and a clogged cat can show up as a bad MAF or MAP due to poor air flow or weird vac readings. Neither of these will damage plugs but can foul them temporarily.

Personally, I would look at fuel pressure before jumping to conclusions. After that see what codes are in the ECM, erase them, then see what comes back as a NEW code for the NEW problem.
Find all posts by this user
Quote this message in a reply
10-10-2014, 04:53 PM
Post: #9
RE: 2nd fuel pump bad
frist time bad fuel pump .they put one in that was bad from the start. 2nd AC fuel pump its was fine working . drove for 6 days stop running the 6th day .took back in shop they looked at again it was the map sensor . starts and runs now but for how lol plus bonus they gave me a new battery free hmm. thanks for all the help rupe -way2old-garner
Find all posts by this user
Quote this message in a reply
10-10-2014, 05:00 PM
Post: #10
RE: 2nd fuel pump bad
Glad you got it resolved and thanks for the follow up. It may help someone else reading here.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)