Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fuel pump not starting all the time in 87' Vanagon.
08-19-2015, 12:28 AM
Post: #1
Fuel pump not starting all the time in 87' Vanagon.
Hi I have a 1987 Transporter, Standard.
I replaced my fuel pump just over a year ago with a brand new one. I haven't driven a lot with it and now sometimes it doesn't start up unless I wack it a few times. I figure it's some kind of fuel pressure switch inside that's malfunctioning. Just wondering, is there is a way to fix it or if I just have to replace it? Thanks for your time! Smile
Find all posts by this user
Quote this message in a reply
08-19-2015, 09:49 AM
Post: #2
RE: Fuel pump not starting all the time in 87' Vanagon.
I presume you are wacking the fuel pump to get it going, right? That's a common problem with cheap replacement parts and possibly made worse by stale fuel which gums things up while the vehicle sits around.

There is no pressure switch. The EFI system just runs the pump with excess fuel pressure returning to the tank.

If you are going to open the system again I suggest you replace the fuel filter as well. Sometimes an old filter can crumble internally and spread all sorts of crap into the system.
Find all posts by this user
Quote this message in a reply
08-19-2015, 01:15 PM
Post: #3
RE: Fuel pump not starting all the time in 87' Vanagon.
(08-19-2015 09:49 AM)Rupe Wrote:  I presume you are wacking the fuel pump to get it going, right? That's a common problem with cheap replacement parts and possibly made worse by stale fuel which gums things up while the vehicle sits around.

There is no pressure switch. The EFI system just runs the pump with excess fuel pressure returning to the tank.

If you are going to open the system again I suggest you replace the fuel filter as well. Sometimes an old filter can crumble internally and spread all sorts of crap into the system.

Yes hitting it appears to get it going and then it works for a while after that. I replaced the fuel filter first actually (it was really new already) and there was no rust or sediment when I poured out the fuel in it. So you think I should get a new fuel pump and spend more money on it? Any suggestions for a good fuel pump that will last me?
Find all posts by this user
Quote this message in a reply
08-19-2015, 05:21 PM
Post: #4
RE: Fuel pump not starting all the time in 87' Vanagon.
Not sure what you spent on it already or if the one you have is still under warranty, which might be worth asking because these things are not cheap no matter what brand you buy. As for which brand is the best replacement, what I can tell you is I have had mixed results from both Airtex and Bosch recently. What I would suggest is calling more than one foreign car parts house and asking about the warranty along with the price. While Bosch was probably the OEM supplier back in the day that Bosch unit you buy here in the states will not come from Germany, which is likely why I have had less than stellar luck.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)