Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Help with PO451 on 2006 Explorer
03-13-2018, 05:10 PM
Post: #1
Question Help with PO451 on 2006 Explorer
A few months ago my fuel pump went out on my 2006 Explorer. I took on the project of replacing it along with the fuel filter. The project went smooth and nothing broke or was damaged. Within a week the check engine light came on reading a PO451 "Evap Emission System Pressure Sensor Performance". I talked to the guys at Auto zone and they recommended replacing the solenoid which I did and I am still having the code come up after resetting it multiple times. I inspected the lines and they are all in good shape and connected properly. The car performs normally and I have put it off for a few months because dropping the tank is quite a pain in the butt. I notice a particularly strong gas oder while filling the tank which makes me think there is a blockage in the evap lines somewhere. I have dropped the tank now and have not noticed any constraints on the lines. I also inspected the tank for any damage and will be replacing the fuel pump assembly gasket. I am almost certain that the code will re-appear and I want to avoid taking this tank out again so any advise as to what to do is so greatly appreciated. I do not know much about the evap system and am not finding many answers online other than to replace the solenoid. IS it possible that the charcoal canister is clogged? or maybe the sensor is malfunctioning? I was thinking on going to a junk yard and possibly picking up a new tank? Any advise is so greatly appreciated!! Thank you!!


Attached File(s)
.jpg  29176834_1818879564858827_1883605324099747840_n.jpg (Size: 77.86 KB / Downloads: 3)
Find all posts by this user
Quote this message in a reply
03-13-2018, 11:18 PM
Post: #2
RE: Help with PO451 on 2006 Explorer
Fuel tank emissions codes can be a little tricky because it's always hard to see what you are dealing with. IOW, things are hidden and usually have 10 years worth of road crud in the way when you need access. OTOH, you have the code and following that will help a great deal.

Here's a little reading to point you in the right direction:

OBD Trouble Code P0451
Evaporative Emission System Pressure Sensor/Switch Range/Performance
What does the code mean? OBD-ii Code P0451 definition:
The EVAP control system pressure sensor detects pressure in the purge line. The sensor output voltage to the ECM increases as pressure increases. The EVAP control system pressure sensor is not used to control the engine system. It is used only for on board diagnosis.
Symptoms of OBD code P0451
– Engine Light ON (or Service Engine Soon Warning Light)
Causes of the OBD-II code P0451
– The EVAP control system pressure sensor circuit is open or shorted – Rubber hose to EVAP control system pressure is clogged, vent, kinked, disconnected or improper connection. – EVAP control system pressure sensor may be faulty – EVAP The Error code is generally activated on detection of the following conditions: – An improper voltage signal from EVAP control system pressure sensor is sent to ECM.

Another longer article:

What Does P0451 Code Mean?
OBD-II Code P0451 is defined as a Evaporative Control System Pressure Sensor Range/Performance
The Code P0451 indicates that the Evaporative Pressure Sensor is indicating pressure change values that are not within specification, during the EVAP Monitor test and/or the operation of the vehicle.
Want to learn more?
The evaporative control (EVAP) system captures any raw fuel evaporating from the fuel storage system (e.g. the fuel tank, filler neck, and fuel cap). Under precise operating conditions—dictated by engine temperature, speed, and load—the EVAP system stores and purges these captured fuel vapors back into the combustion process. The Fuel Tank Pressure Sensor is a device that tracks any positive or negative pressure changes in the Fuel Storage or Evaporative Control (EVAP) system. It constantly relays this pressure information to the Powertrain Control Module (PCM). The Fuel Tank Pressure Sensor is located on top of the Fuel Tank, or on or near the Fuel Pump and Fuel Gauge Module.
Symptoms
Check Engine Light will illuminate
In most cases, there are no adverse conditions noticed by the driver
In some cases, there may be a noticeable fuel odor caused by the release of fuel vapors
Common Problems That Trigger the P0451 Code
Defective Fuel Tank Sending Unit
Defective or damaged Fuel Tank
Defective Fuel Tank Pressure Sensor, wiring, or computer
Defective Carbon Canister
Defective Canister Vent Valve - in some cases
Common Misdiagnoses
Fuel Cap
Evaporative Purge Valve
Evaporative Vent Valve
Polluting Gases Expelled
HCs (Hydrocarbons): Unburned droplets of raw fuel that smell, affect breathing, and contribute to smog
The Basics
The Fuel Tank Pressure Sensor is a device that tracks any positive or negative pressure changes in the Fuel Storage or Evaporative Control (EVAP) system. It constantly relays this pressure information to the Powertrain Control Module (PCM). The Fuel Tank Pressure Sensor is located on top of the Fuel Tank, or on or near the Fuel Pump and Fuel Gauge Module.
P0451 Diagnostic Theory for Shops and Technicians
The Evaporative Control System Pressure Sensor Range/Performance code sets when the readings of the Pressure Sensor are irrational and/or out of range for ten seconds of vehicle operation after a cold start. This code uses "two trip" logic, which means that the fault condition must be present during two successive cold starts and vehicle operation.

Common Tests for the Evaluating the Fuel Tank Pressure Sensor

Retrieve the code and write down the freeze frame information to be used as a baseline to test and verify any repair.
Pay very close attention to the Fuel Tank Pressure readings by observing its data stream on a scan tool. Does the Fuel Tank Pressure Sensor work properly? If it doesn't, the system will think that no vacuum is being created when, in fact, there is a vacuum being created that the Fuel Tank Pressure Sensor is unable to read. The Fuel Tank Pressure Sensor is the primary feedback sensor that the Powertrain Computer relies on for the leak test data.
Inspect and test the Fuel Pressure Sensor wiring. Verify that there is a 5-volt reference signal from the PCM, a good ground, as well as a good signal return circuit to the PCM.
While observing the data stream change (or lack there of) on a scan tool, test the Pressure Sensor with a Vacuum Gauge while it is connected to the wiring harness.
If all of the above test results are within spec, then the problem may reside in the PCM itself.

Let us know what you find as it may help others reading here.
Find all posts by this user
Quote this message in a reply
03-14-2018, 06:26 AM
Post: #3
RE: Help with PO451 on 2006 Explorer
I would like to add another resource that may help. You mentioned the smell of gas. This would indicate a leak somewhere which could cause the problem. You can try to follow the smell with your nose to find that leak. Sometimes it is the gas cap, the metal filler neck has a hole rusted in it, hose clamps on the filler neck connections are loose...check everything. If you still can't locate the leak some shops have a tool called a "Smoker." They can hook up a machine that forces smoke into the system and you can then see it escaping at the leak site. This can sometimes be pretty expensive, like 40 to 50 bucks. But buying one part that you don't need can cost that much. So it can actually save time and money in the long run.

Hope that may help. Please let us know what you find.

Thanks for using the forum,
Garner

Interested in Mining? Look here: Coal Mining, PA
Visit this user's website Find all posts by this user
Quote this message in a reply
03-18-2018, 01:44 AM
Post: #4
Wink RE: Help with PO451 on 2006 Explorer SOLVED!!
UPDATE! I followed the very helpful advise on this page and located the pressure sensor. With the intention of removing it I unplugged the wire harness and noticed that one of the pins was damaged. I remember when I installed the pump assembly that this connection was very hard to push in to place, and considering its not Motocraft the quality is not as good as it could be either. I was able to use the old harness of the original assembly save some dough. Put the tank back up and have driven 60+ miles with no CEL. Thanks again for your help! I was able to save hundreds by figuring this out rather than taking it to a mechanic.


Attached File(s)
.jpg  29342951_1824651714281612_6790028542592679936_n.jpg (Size: 41.44 KB / Downloads: 2)
Find all posts by this user
Quote this message in a reply
03-18-2018, 11:19 PM
Post: #5
RE: Help with PO451 on 2006 Explorer
Thanks for the follow up, as not everyone does that. It helps all who read here to gain from your experience!
Find all posts by this user
Quote this message in a reply
03-19-2018, 10:58 AM
Post: #6
RE: Help with PO451 on 2006 Explorer
Awesome! Thanks for the follow up and the picture of the damaged plug. This could help someone else.

Thanks for using the forum,
Garner

Interested in Mining? Look here: Coal Mining, PA
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)