Thread Closed 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
turbo no longer working !
01-14-2010, 11:41 AM
Post: #1
turbo no longer working !
Year: 1996
Model: 850 R
Engine Size: 2.3
Auto/Manual: auto
Mileage: 232000 kms

hi everybody ,
i wonder if if anyone can help me , i recently took my 850 r out of mothballs after a long welll earned break, i renewed the fuel, checked all the hoses , fitted a new battery the she ran like a dream for about 3 weeks . since then i did not use her for 6 weeks as i was working away. when i came home the battery was dead , so i just recharged it.
now i have no turbo power whatsoever whilst driving. the guage shows boost , but no power goes to the engine, it is a bit like driving a quicker version of my wifes non turbo wagon ( 850 cd).
i have put in new fuel and injector cleaner and checked all apppropriate levels but no luck ?
any advice would be appreciated.

thanks michael
Find all posts by this user
01-15-2010, 12:49 AM
Post: #2
RE: turbo no longer working !
If you are showing boost then chances are the turbo is working. OTOH, it here a substantial lack of power you may have a clogged cat converter or a restricted fuel flow.

In retrosprct, the fact that you have boost means the exhaust flow must be enough to get the turbo spinning so I'd be looking at fuel issues. (clogged injectors, low pressure, etc) You might also double check the air filter for restriction since mice tend to nest in places like that when a vehicle is parked for long periods. IOW, it might be full of temporary guests and their "stuff".
Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)