Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2000 Montero Sport AC Unit
05-20-2011, 03:08 PM
Post: #1
2000 Montero Sport AC Unit
My 2000 Montero Sport ES 3.0 in Jacksonville, FL is having air conditioner problems, since last summer.

The unit started to blow warm air last summer year so I checked the freon level and it was fine, but I ended up putting some in to make sure there was enough. it became over charged and stayed that way for about a month, then I ended up removing all the freon and putting in the new type of freon they have on the market along with the oil that is supposed to be in the AC system.

it ran fine until about two weeks ago and now it only blows warm air and everything seems to check out. When I turn the AC unit on it does blow and the engine does idle a little higher.

Since the system is not leaking and it is obviously turning on, what do you think the problem is? Any help would be great, thank you.
Find all posts by this user
Quote this message in a reply
05-21-2011, 10:28 AM
Post: #2
RE: 2000 Montero Sport AC Unit
AC work is not hard but since the inner workings are hidden from view it's almost impossible to do any sort of serious diagnosis without a set of gauges.

OTOH, something you can check is to see if the compressore clutch is actually turning when you switch it on. Just observe the center section on the pulley and have someone cycle the switch. After that you can feel the pipes where they go through the heater case. One should be cold and the other warm. If the clutch doesn't turn the compressor then nothing else will work.

BTW, that slight increase in idle is only the signal from the AC switch to the engine computer getting things ready. It's not an indication of the AC itself working.

Let us know how you make out.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)