Thread Closed 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
help with my a/c, please!
05-23-2007, 02:02 AM
Post: #1
help with my a/c, please!
I have a 2000 Jeep Cherokee Sport, 4.0 automatic with 150k miles.

When I first turn on my a/c, it blows cold for about 3-5 mins, then starts gradually (and rapidly) blowing warm air. It will continue blowing warm air until I shut it off, and leave it off for about 10 - 20 mins. Then, after the 10 - 20 mins of being completely shut off, if I turn it back on it will be blowing cold air again, which only lasts (again) for about 3 - 5 mins, at which point it begins blowing warm air again, followed by the same cycle of shutting it off and waiting and then starting over again.

It was checked/filled with refrigerant and still does the same thing.

Any ideas? Summer is coming and the wife and kids will be NO FUN to listen to this summer unless the a/c is blowing cool air for more than a few minutes here and there.
Find all posts by this user
05-23-2007, 01:10 PM
Post: #2
RE: help with my a/c, please!
It sounds like the compressor is cycling out, which is normal depending on conditions. But when power is restored for the compressor clutch to engage, the electo-magnet is not pulling the hub into the pulley. When the A/C begins blowing warm, try taking a hammer and tap on the front of the compressor hub. If it engages thats the problem. You would need to replace the pulley and hub assm. which comes with the elerco-magnet.

Cary Joe York
Support
Find all posts by this user
Thread Closed 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)