Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
geo 1991 metro
01-16-2012, 07:51 PM
Post: #1
geo 1991 metro
i changed the head gasket on my 1991 geo metro with 1.0 motor and now the fuel pump will not come on, i jump the pump with a battery and it works, i put a new pump relay in and the pump still will not work, if i spray engine starting fluid in the injector the motor runs until it burns off. what else could i check?
Find all posts by this user
Quote this message in a reply
01-16-2012, 09:02 PM
Post: #2
RE: geo 1991 metro
There is a possibility a wire was left unplugged or possibly a wire pinched somewhere. Check all fuses also. Use a test light on both sides of the fuse tpo be syre there is current flowing through it. Check at the pump to see if there is any current, and if not, work your way forward to see where the current shows. There is no easy way to find the problem, just time and patience.

Being way2old is why I need help from younger minds.



[Image: crybaby.jpg]
Find all posts by this user
Quote this message in a reply
01-16-2012, 11:19 PM
Post: #3
RE: geo 1991 metro
Found this on the web but it's for a 92, which may be similar enough to get you out of the woods.

Along the top of the page there's a series of pix someone took from their shop manual and they are VERY clear so you can zoom in. I believe the second one may be what you are needing.

http://metroxfi.com/2008/11/geo-metro-an...-diagrams/

If all else fails you can likely get further info through http://www.autozone.com and after creating a free account you can go to their DIY section then enter the make / year to get more.

Let us know how you make out.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)