Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
inspection failure
11-06-2013, 05:05 PM
Post: #1
inspection failure
Went to get my 2001 gmc jimmy inspected yesterday and failed with codes P0128 and P0300. Just put new thermostat into truck this past weekend, I am running water in it now .... so if yall can turn me into the right direction thank you
Find all posts by this user
Quote this message in a reply
11-06-2013, 05:44 PM
Post: #2
Inspection failure
P0128 is a coolant temperature code but more than one thing can cause it. Click on the link to read through some common causes.

P0128 Code

P0300 is Random Misfire. That could be caused by the computer thinking that the engine is the wrong temperature; too cold, and adding fuel to compensate? That causing a flooded condition & a misfire.

Please let us know what you find.

Thanks for using the forum,
Garner

Interested in Mining? Look here: Coal Mining, PA
Visit this user's website Find all posts by this user
Quote this message in a reply
11-06-2013, 06:58 PM (This post was last modified: 11-06-2013 07:02 PM by Rupe.)
Post: #3
RE: inspection failure
If this is a 4.3 engine I'll bet good green $$ it's got one of the following issues, mostly due to age or mileage. (I have a fleet of these things)

Multi-cyl misfire can come from the ignition, such as coil, wires, cap /rotor, or worn distributor. (shaft wobble)

The other likely cause is fuel delivery. IOW, partially clogged filter or early signs of a tired fuel pump. The pumps fail any time after 100k miles and typically 120 - 140k miles in my experience.

If you can't recall the last time you did a full tune up then that's where I would go first. I know OEM parts for this are not cheap but it's a good investment for the next 100k miles.

On the temp sensor issue if you have access to a full function scanner then you can look at the actual temp the ECU sees. If it's out of range then this might contribute to your misfire as well. The fix for that is a new sensor as you have already done the t-stat with a new 195 degree unit, right? If you put in a 180 or 160 'stat that may also be an issue. The engine must run higher than that for everything to be right.

BTW, injectors rarely go bad on these things. Half of my fleet is over 200k miles (some pushing 300k) and I have only done injectors maybe twice in the last 10 years.

Let us know how you make out.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)