Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2001 2.2 OHV Cavalier will only idle
02-24-2014, 05:13 PM
Post: #1
2001 2.2 OHV Cavalier will only idle
2001 Cavalier with a 2.2 OHV automatic trans, [/size][/font]will not take gas. The engine will not pop a code.  Removed various components and the code pops.  Erase and try again.  This engine just gags the more you give it the gas. With the TB exposed, I shot a little ether while a buddy was trying to accelerate.  It kills it immediately.  I did a fuel pressure test: 53#, the minimum.  Fuel flow volume is good.  Crimped the return from regulator to rule it out.  Replaced new ignition module, coil packs, spark plug wires and plugs.  Checked all injectors with a stethoscope.  All clicking nicely.  Compression test OK.  1 - 165, 2 - 165, 3 - 158, 4 - 155.  Not bad for 100,000 miles.  There is no clicking like a damaged tensioner on the timing chain.  I can't find any timing marks to try a light.  Tested the MAP.  Its OK.  5 volts down to 1 volt as vacuum is applied.  I removed each spark plug wire while running.  Each one made it fall on its face.   

This car kind of runs like it jumped time.  But wouldn't that show up in the compression test?  With no codes to work with, I'm in the blind and just throwing money at it to no avail.   As you open the throat on the throttle body, it sounds like its not getting gas, but give it a little ether, no matter how little, and it stalls. 

Any suggestions will be appreciated.   
Find all posts by this user
Quote this message in a reply
02-24-2014, 09:00 PM
Post: #2
RE: 2001 2.2 OHV Cavalier will only idle
Have you checked for a restricted exhaust? Without actually being there that's the only thing that comes to mind at the moment.

Please keep us posted as to what you find.

Thanks for using the forum,
Garner

Interested in Mining? Look here: Coal Mining, PA
Visit this user's website Find all posts by this user
Quote this message in a reply
02-24-2014, 10:16 PM
Post: #3
RE: 2001 2.2 OHV Cavalier will only idle
Easy trick to try....

Pull the front O2 sensor right out of the pipe but leave the wire plugged in. This should allow the ECM to not default right away and also give you more breathing room if the exhaust is restricted. Obviously it will make a lot of noise but at least you can see if less restriction makes a difference.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)